Pollin Net-IO

Umrüstung Pollin NetIO auf Schaltregler

Leider ist diese Variante gründlich “versaut” wurden. Der Schaltregler arbeit super, aber die 3,3V habe ich leider von der Pinbelegung her, wie einen 7805 entworfen. Die 3,3V werden aber auf dem NET-IO mit einem LM317 erzeugt, der ein anderes Layout hat :-(

Eine wirklich gute und funktionierende Schaltung, die ich jetzt auch mit Erfolg für meinen Pollin Net-IO benutze findet ihr in der Beschreibung Strom für NET-IO mit LT1933.

Hintergrund

Seit längerem spiele ich mit einem Miniwebserver mit Atmel CPU rum. Genauer, dem NetIO, den es bei Pollin als Bastelsatz (und neuerdings auch fertig bestückt) gibt. (Infos zum NetIO am Besten über http://www.mikrocontroller.net/articles/AVR_Net-IO_Bausatz_von_Pollin)

Das Teil im allgemeinen ganz gut. Nur die 5V und 3,3V Spannungsversorgung ist mit Linearregler gelöst. Bei meinen 12V Netzteil als Eingang und den ca. 190mA Strom wird besonders der 5V Regler (7805) sehr warm. Ohne einen kleinen Kühlkörper würde es auf dauer nicht gehen. Somit war klar, hier muss ein Schaltregler her.

Bisher habe ich nur Erfahrung mit dem MC34063, wollte aber auf den LM2574 wechseln. Somit war ein neues Projekt geboren…

Vorbereitung

Da der 3,3V Linearregler 5V als Eingang bekommt, wird dieser nicht besonders warm. Meine erster Plan war, nur den 7805 auszutauschen. Leider ist aber der Platz arg begrenzt und leider auch in der Tiefe durch einige Bauteile etwas verbaut. Etwas mehr Platz hat man, wenn man in Richtung 3,3V Regler rückt. Somit war klar, dass alles per Schaltregler gemacht wird.

Mit dem Messschieber die max. Breite und Höhe der Platine “geschätzt” und geschaut wo etwas Platz “nach hinten” für die Kondis ist. Da ich die LM2574 als DIL Variante da hatte und ein paar LOW ESR Kondis in SMD Bauform, war klar, dass es eine Mischbestückung wird. D.h. einseitige Platine, auf der erst die ICs und Bauelemente mit “Drahtbeinen” bestückt und danach von der Kupferseite die SMD Bauelemente aufgepfropft werden. Manchmal mache ich aus DIL Schaltkreisen mit einem Seitenschneider auch SMD Varianten, doch hier kommt aufgrund des Platzes in der Tiefe eine Bestückung auf beiden Seiten recht.

Als Schaltregler habe ich die mit fest eingestellter Spannung genommen (und beim Bestücken festgestellt, dass ich nur zwei 5V Typen da hatte - gut für Reichelt… :-).

Aufbau

Die Platine wurde mit Eagle entworfen. Leider habe ich beim Berechnen der Masseflächen etwas zu wenig Isolierabstand gelassen. Das hat mir eine Stromversorgung gekostet, dazu später mehr.

Ich hänge hier mal alle Eagledateien rein (netio_7805_ersatz_all.zip). Für Nicht-Eagler gibt es auch normale Bilder. Ich habe bei der Leiterplatte zwei Striche mit jeweils 15mm eingezeichnet. Somit kann man prüfen, ob der Drucker das Bild richtig zu Papier bringt. 0,5mm Abweichung sind unkritisch, ab einem Millimeter muss man den Schaltkreis schon arg in die Löcher quetschen.

Vorlage - Bild herunterladen, hat genügend Auflösung und wird hier nur 800px Breit dargestellt.

Bestückung - Top und Bottom für nicht Eagle Nutzer. Beim Bestücken zuerst Top, danach C1 und C3 auf Bottom, zum Schluss C2 und C4.

Leiterplatte vor dem ätzen. Die Beschichtung wurde durch meinen umgebauten Laminierer aufgebracht. (Siehe Laminatorumbau für Leiterplatten)

Leiterplatte nach dem Ätzen, bevor mit Aceton der Toner entfernt wird. Die Strukturen sehen verwaschen aus. Das liegt aber am Toner. Die Kupferbahnen sind super.

Nach dem Reinigen der Leiterplatte wische ich die Kupferfläche mit einem Tuch ab, auf das etwas Kolophoniumlösung ist. Die Lösung ist eine relativ dicke Soße aus in Methanol gelöstem Kolophonium (ist noch “Made in GDR” und wurde in Vaters Betrieb in Mengen verwendet). Diese Lösung strecke ich nochmals mit ordentlich Aceton, so dass auf dem Cupfer nur eine dünne Schicht bleibt. Durch das Aceton klebt diese Schicht auch so gut wie nicht. Es lässt sich dann besser löten und die Kupferbahnen oxidieren nicht.

Bestückungsseite, die Diode der 5V Seite (rechts) ist wegen Fehlersuche und Bequemlichkeit auch auf die Kupferseite gewandert.

Kupferseite, eher unspektakulär. Für die Skeptiker des Tonertransferverfahrens zum Ätzen - die locker erreichten Stukturen, z.B. der Schrift, reichen für Hobbyaufgabe völlig.

Wer noch feinere Strukturen baut, ist sich im (Semi-)Professionellen Bereich angesiedelt.

Test

Nach dem Aufbau und dem Durchmessen mit einem Ohmmeter, habe ich die Schaltung an meine Stromversorgung gehängt. Der Test dauerte nur einem Bruchteil einer Sekunde - denn es gab einen lauten Knall in meiner Stromversorgung. Erst dachte ich, es wäre ein Problem durch den Einschaltstrom - nein es war ein schnöder Kurzschluss durch ein Kondensatorbeinchen und einem Lötzinnrest, der wohl durch mechanische Beanspruchung nach dem Durchmessen entstanden ist. Hätte ich beim Masseflächeberechnen einen größeren Isolierabstand gewählt, wäre es nicht passiert :-(. Aber so ist dass, wenn man Ätzmittel sparen will…

Meine Homemade-Laborstromversorgung besteht übrigens aus zwei getrennten Schaltreglern mit MC34063 und eingebauten Strom- und Spannungsmesser in einem geläppten V4A Gehäuse. Das Gehäuse hat in den 80ern mal mein Vater für mich gebaut und ist 1A Qualität… Die Qualität meiner reingeschmiedeten Elektronik aber weniger. Aus Mangel eines Halbohmwiderstandes, wurde dieser durch eine Drahtbrücke ersetzt. Das war nun der Schaltkreistod. der MC34063 ist regelrecht explodiert. Ein Teil der Verkappung ist abgesprengt wurden. Aber ich wollte schon immer mal eine Seite der Versogung durch einen LM2576 Regler, der ein paar Ampere kann, ersetzen.

Nach dem Finden und Beheben des Fehlers läuft das Ding einwandfrei. 5,02V auf der 5V Seite und 3,3 Volt auf der 3,3V Seite.Den Ripple habe ich noch nicht gemessen, kommt aber noch.

Messung

Den Ripple habe ich gemessen, Bilder und Kommentare kommen noch. Kurzfassung: 5V: wenig oder unbelastet < 5mV; bei 200mA ca. 8mV; 3,3V wenig oder unbelastet < 3mV; bei 200mA ca. 5mV.

Ich habe eine erste Messung zum Wirkungsgrad gemacht und war etwas enttäuscht. Mal sehen wenn die Eingangsspannung höher ist, wie der Wirkunsgrad sich entwickelt. Folgende Werte habe ich gemessen:

Spannung Strom Widerstand Leistung
Eingang 9,8 V 182 mA 1783 mW
5V Out 4,98 V 130 mA 38 Ohm 647 mW
3,3V Out 3,26 V 82,5 mA 39 Ohm 269 mW

Daraus ergibt sich am Ausgang eine Leistung von insgesamt 916 mW oder nur 51,4% :-(

Da bei den relativ kleinen Strömen auf Dauer die 5V Spule doch sehr warm wird, denke ich, dass die nicht die erste Wahl für Schaltregler ist. Die Spule ist für 300 oder gar 350 mA spezifiziert.

Noch etwas anderes am Rande - als Last habe ich jeweils einen Widerstand mit 22R verwendet. Der errechnete Widerstand liegt “etwas” daneben. Können Widerstände altern? (Ist noch Made in GDR Ware aus einer Schrittmotoreinheit und nach der Platine zu urteilen mindestens Anfang 80er oder noch älter…)

Strom für NET-IO mit LT1933

Nachdem mein erster Ansatz das NET-IO Board etwas effizienter im Stromverbrauch zu machen, schief gingen, hier der 2. Anlauf mit erfolg :-)

Auf einen Aufbau mit dem LT1933 bin ich durch eine sehr kompakte Schaltung auf mikrokontroller.net (http://www.mikrocontroller.net/articles/5V/3V3_DC/DC-Wandlerboards) gekommen. Diese habe ich ohne Modifikationen übernommen.

Folgend ein paar Bilder:

Ich habe gleich 4 Platinen gemacht, da der schmale Streifen eh nicht mehr für etwas anderes zu gebrauchen ist. Mit dem umgebauten Laminierer das Layout aufgebracht in meiner Eigenbau-Küvette geätzt und anschließend mit der Heißluftpistole und Fittingpaste verzinnt

Die Platine mit Kolophoniumlösung (Kolophonium in Methanol - noch ostdeutscher Restbestand) eingepinselt und dann auf den klebrigen Film die SMD Teile platziert. Mit einem Holzspieß habe ich die Teile von oben beim Löten fixiert. Durch das Vorverzinnen und dem Kolophoniumüberzug ging das Lötenrasch und ohne Probleme. Ist übrigends meine erste “Voll-SMD” Platine ;-)

So sieht der Schaltregler als Ersatz für den 7805 aus.

Und nochmal von oben.

Der Umbau hat sich sehr gelohnt. Der Schaltregler wird nicht mal Handwarm. Der Stromverbrauch des NET-IO ist eingangsseitig von 187mA auf 112mA gesunken.

Ich habe mal den Wirkungsgrad berechnet. Das Ergebnis kommt mir etwas zu hoch vor. Soll sich jeder sekber ein Bild machen. Hier mal die Messung an zwei verschiedenen ohmsche Lasten.

Spannung IN Strom IN Spannung OUT Strom OUT Wirkungsgrad
Last 1 10V 40mA 4,98V 76,5mA 95,25%
Last 2 10V 75mA 4,98V 136,8mA 90,4%

Ich hätte gedacht, das bei stärkerer Last der Wirkungsgrad steigt.

Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Share Alike 4.0 International